FedEx Web Services degraded performance

Incident Report for ShipHawk

Resolved

Resolved on FedEx side.
Posted Sep 02, 2026 - 14:59 PDT

Monitoring

FedEx web services are currently experiencing degraded performance, and some customers have reported issues booking FedEx shipments. We will continue to monitor the situation while FedEx works to resolve the issue.
Current FedEx response times are available here: https://www.shippingapimonitor.com/history.html?api=fedex
Posted Sep 02, 2026 - 09:24 PDT
This incident affected: Carrier/3PL Connectors (FedEx Web Services).