Major AWS service outage

Incident Report for ShipHawk

Resolved

The AWS issue affecting carriers has been resolved.
Posted Oct 20, 2025 - 16:28 PDT

Monitoring

Amazon Web Services had a major outage today that effected a large number software services across the internet, including ShipHawk. While ShipHawk's software did not go down, the outage has intermittently affected some carriers regarding rating and label generation. Everything is working currently and we are working with AWS to ensure system responsiveness.
https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 13:56 PDT

Investigating

Amazon Web Services had a major outage today that effected a large number software services across the internet, including ShipHawk. While ShipHawk's software did not go down, the outage has led to intermittent reliability for many parcel and LTL carriers regarding rating and label generation. We are working with AWS to resolve these issues as soon as possible.
https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 13:37 PDT