FedEx API degraded performance

Incident Report for ShipHawk

Resolved

Resolved by FedEx
Posted Jun 26, 2026 - 13:49 PDT

Monitoring

We are seeing a degraded performance with FedEx API, some customers reported issues with booking FedEx shipments. We are actively monitoring the situation and will provide updates as soon as more information becomes available or the issue is resolved.
Posted Jun 26, 2026 - 08:47 PDT
This incident affected: Carrier/3PL Connectors (FedEx Web Services).