UPS web services - degraded performance
Incident Report for ShipHawk
Resolved
This incident has been resolved.
Posted Nov 05, 2020 - 20:45 PST
Investigating
We are seeing degraded performance with response times from UPS web services.

For more on UPS web service response times: https://www.shippingapimonitor.com/history.html?api=ups
Posted Nov 05, 2020 - 13:34 PST
This incident affected: UPS API.