WWEX / SpeedShip services outage

Incident Report for ShipHawk

Resolved

Confirmed as resolved by WWEX.
Posted Sep 29, 2025 - 15:40 PDT

Identified

Customers using WWEX / SpeedShip integrations may experience issues with rating and booking shipments due to an outage of the WWEX / SpeedShip API. The provider has notified us that they are actively working on a resolution. We will continue monitoring and provide updates as they become available.
Posted Sep 29, 2025 - 11:05 PDT