Investigating reported issue with booking shipments
Incident Report for ShipHawk
Resolved
Status update: This issue is resolved.

Customer Impact: Some customers are seeing the following error when attempting to book some of their shipments: “There was a problem booking your shipment: Couldn’t find Shipment with ‘id’= [WHERE “shipments”.“deleted_at” IS NULL AND “shipments”.“crm_instance_id” = $1]”. This error prevents them from booking the shipment. A workaround is possible and requires an administrative change by our team. If you experience this issue, contact our support team for assistance.

Start Time: April 1, 7:12 AM PST
End Time: April 1, 10:00 AM PST
Posted Apr 01, 2022 - 11:34 PDT
Monitoring
Status update: A fix has been implemented and we are monitoring the results

Customer Impact: Some customers are seeing the following error when attempting to book some of their shipments: “There was a problem booking your shipment: Couldn’t find Shipment with ‘id’= [WHERE “shipments”.“deleted_at” IS NULL AND “shipments”.“crm_instance_id” = $1]”. This error prevents them from booking the shipment. A workaround is possible and requires an administrative change by our team. If you experience this issue, contact our support team for assistance.

Start Time: April 1, 7:12 AM PST
Posted Apr 01, 2022 - 10:13 PDT
Identified
Status update: We have identified the issue and are working towards a resolution.

Customer Impact: Some customers are seeing the following error when attempting to book some of their shipments: “There was a problem booking your shipment: Couldn’t find Shipment with ‘id’= [WHERE “shipments”.“deleted_at” IS NULL AND “shipments”.“crm_instance_id” = $1]”. This error prevents them from booking the shipment. A workaround is possible and requires an administrative change by our team. If you experience this issue, contact our support team for assistance.

Start Time: April 1, 7:12 AM PST
Posted Apr 01, 2022 - 08:45 PDT
Investigating
Status update: We are investigating this issue.

Customer Impact: Some customers are seeing the following error when attempting to book some of their shipments: “There was a problem booking your shipment: Couldn’t find Shipment with ‘id’= [WHERE “shipments”.“deleted_at” IS NULL AND “shipments”.“crm_instance_id” = $1]”. This error prevents them from booking the shipment. A workaround is possible and requires an administrative change by our team. If you experience this issue, contact our support team for assistance.

Start Time: April 1, 7:12 AM PST
Posted Apr 01, 2022 - 08:29 PDT
This incident affected: ShipHawk Application.