Partial USPS Endicia Web Services outage

Incident Report for ShipHawk

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 19:17 PDT

Monitoring

We are seeing a degraded performance with USPS Endicia web services. We will continue to monitor as USPS Endicia works to resolve this.

https://status.endicia.com
Posted Jun 19, 2026 - 08:38 PDT
This incident affected: Carrier/3PL Connectors (USPS via Endicia).