Partial USPS Endicia Web Services outage

Incident Report for ShipHawk

Resolved

Resolved by USPS Endicia
Posted Oct 10, 2025 - 11:18 PDT

Investigating

We are seeing a degraded performance with USPS Endicia web services. We will continue to monitor as USPS Endicia works to resolve this.
https://status.endicia.com
Posted Oct 10, 2025 - 10:51 PDT
This incident affected: Carrier/3PL Connectors (USPS via Endicia).